Email Delivery Issues - Microsoft 365 (Business or Enterprise)

Incident Report for Tradify

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 19:51 NZDT

Update

Microsoft have a high level of confidence that the incident is largely resolved and are indicating mail flow remains stable.

Tradify will continue to monitor the situation.

Further details can be found https://status.cloud.microsoft/
Posted Jan 23, 2026 - 18:46 NZDT

Update

We are continuing to monitor for any further issues.
Posted Jan 23, 2026 - 18:45 NZDT

Monitoring

Microsoft are reporting positive signs of recovery in mail delivery but are still actively working on full recovery.

Further details can be found here https://status.cloud.microsoft/
Posted Jan 23, 2026 - 18:15 NZDT

Update

Microsoft are continuing to see steady improvements in their services impacting email.

Further details can be found here https://status.cloud.microsoft/
Posted Jan 23, 2026 - 16:33 NZDT

Update

The issue has been identified as an issue with emails being delivered to Microsoft 365 mailboxes. Further details can be found at
Posted Jan 23, 2026 - 15:45 NZDT

Update

We are continuing to work on a fix for this issue.
Posted Jan 23, 2026 - 15:45 NZDT

Identified

The issue has been identified as an issue with emails being delivered to Microsoft 365 mailboxes. Further details can be found at

https://status.cloud.microsoft/m365
Posted Jan 23, 2026 - 15:31 NZDT
This incident affected: 3rd Party Systems (SendGrid) and Tradify (Email Notifications).