Scheduled Maintenance
Incident Report for Tradify
Resolved
This incident has been resolved.
Posted Aug 07, 2022 - 11:21 NZST
Monitoring
Some UK and global customers will be impacted by server maintenance that is taking longer than planned. We apologise for the inconvenience and expect to be back up and running within a few hours.
Posted Aug 07, 2022 - 08:45 NZST
This incident affected: Tradify (Web Portal, Mobile App (iOS), Mobile App (Android), TradeHQ).