Scheduled Maintenance
Incident Report for Tradify
Resolved
This incident has been resolved.
Posted Jan 01, 2024 - 18:43 NZDT
Identified
We will be undergoing scheduled maintenance during this time.
Posted Jan 01, 2024 - 06:20 NZDT
This incident affected: Tradify (Web Portal, Email Notifications, Mobile App (iOS), Mobile App (Android), TradeHQ).