Slow Response Time
Incident Report for Tradify
Resolved
This incident has been resolved.
Posted Oct 09, 2023 - 18:49 NZDT
Identified
The issue has been identified and we are working on a fix. Apologies if you are currently experiencing longer than expected load times
Posted Oct 09, 2023 - 11:01 NZDT
Investigating
We are investigating an issue with slow response time for some users
Posted Oct 09, 2023 - 09:54 NZDT
This incident affected: Tradify (Web Portal, Mobile App (iOS), Mobile App (Android)).